Marine Navigation Calculator

Developed by NGA staff (formerly NIMA)
Reformatted and distributed by
Starpath School of Navigation

Log and Trig Calculator

Celestial Navigation Calculator

Conversions Calculator

Distance Calculator

Time Measurements and Conversions Calculator

Weather Data Conversion Calculator

Sailings Calculator

Log and Trig Calculator
Logarithmic and Trigonometric Functions
Celestial Navigation Calculator
 | Altitude Correction for Air Temperature
 | Altitude Correction for Atmospheric Pressure
 | Altitude Factors & Change of Altitude
 | Amplitude
 | Correction of Amplitudes Observed on the Visible Horizon
 | Latitude and Longitude Factors
 | Meridian Angle and Altitude of a Body on the Prime Vertical Circle
 | Pub 229
 | Table of Offsets

Conversions Calculator
 | Chart Scales and Conversion for Nautical and Statute Miles
 | Conversion for Meters, Feet and Fathoms

Distance Calculator
 | Dip of Sea Short of the Horizon
 | Distance by Vertical Angle Measured Between Sea Horizon and Top of Object Beyond Sea Horizon
 | Distance by Vertical Angle Measured Between Waterline at Object and Top of Object
 | Distance by Vertical Angle Measured Between Waterline at Object and Sea Horizon Beyond Object
 | Distance of an Object by Two Bearings
 | Geographic Range
 | Distance of the Horizon
 | Length of a Degree of Latitude and Longitude
 | Meridional Parts
 | Speed for Measured Mile and Speed, Time, and Distance
 | Traverse Table
Time Measurements and Conversions Calculator
Time Zones, Zone Descriptions, and Suffixes
Weather Data Conversion Calculator
 | Correction of Barometer Reading for Gravity
 | Correction of Barometer Reading for Height Above Sea Level
 | Correction of Barometer Reading for Temperature
 | Barometer Measurement Conversions
 | Temperature Conversions
 | Direction and Speed of True Wind
 | Relative Humidity and Dew Point

Sailings Calculator
 | Great Circle Sailing
 | Mercator Sailing


Altitude Correction for Air Temperature

Apparent Altitude: | (degrees)
 | (minutes)
Air Temperature: (Specify Units) |
 | degrees Fahrenheit | degrees Centigrade
Altitude Correction: | (minutes)


Amplitude Computations Home Page

Amplitude Calculator

Compute the Amplitude (A) of celestial bodies at rising and setting given the Latitude of the Observer (L) and the declination of the celestial body (d).

Latitude of the Observer: | (degrees)
Declination of the Celestial Body: | (degrees)
Amplitude: | (degrees)


Correction of Barometer Reading for Gravity Home Page

Correction of Barometer Reading for Gravity

Latitude: | (degrees)
Observed Reading of the Barometer: | (inches of mercury)
Barometer Correction: | (inches of mercury)


Correction of Barometer Reading for Height Above Sea Level Home Page

Correction of Barometer Reading for Height Above Sea Level

Height of the Barometer Above Sea Level: | (feet)
Outside Temperature: | (° F)
Barometer Correction: | (inches of mercury)


Correction of Barometer Reading for Temperature Home Page

Correction of Barometer Reading for Temperature

Temperature: | (° F)
Observed Reading of the Barometer: | (inches of mercury)
Barometer Correction: | (inches of mercury)


Distance of an Object by Two Bearings

First Bearing to Object: | (degrees)
 | (minutes)
Second Bearing to Object: | (degrees)
 | (minutes)
Distance Between Bearings: |
Distance to Object at Bearing 2: |
Distance to Object When Abeam: |


Correction of Amplitude Observed on the Visible Horizon Home Page

Correction of Amplitudes Observed on the Visible Horizon

Latitude of the Observer: | (degrees)
Declination of the Celestial Body: | (degrees)
Corrected Azimuth Angle: | (degrees)


Length of a Degree of Latitude and Longitude Computation Home Page

Length of a Degree Of
Latitude and Longitude

This page allows calculation of one degree of latitude and longitude. Lengths are calculated in nautical miles, statute miles, feet, and meters.

Latitude: | (degrees)
Length of a Degree of Latitude:
Meters: |
Feet: |
Nautical Miles: |
Statute Miles: |
Length of a Degree of Longitude:
Meters: |
Feet: |
Nautical Miles: |
Statute Miles: |


Distance of the Horizon/ Geographic Range Home Page

Dip of the Sea Short of the Horizon

Height of Eye of the Observer Above Sea Level (specify units): |
 | feet | meters
Distance to the Waterline of the Obstruction: | (Nautical Miles)
Dip Short of the Sea Horizon: | (Minutes of Arc)


Altitude Factors Home Page

NIMA Standard Seal

Altitude Factors and Change of Altitude in Given Time From Meridian Transit

Altitude Factors

This form calculates the change in the altitude of a celestial body in one minute of time from meridian transit. The values are accurate if the altitude is between 6° and 86°, the latitude is not more than 60°, and the declination is not more than 63°. The result is used as input to the following form.

Latitude of the Observer: | (degrees)
Declination of the Celestial Body: | (degrees)
Upper Transit Lower Transit
Altitude Factor: | (seconds of arc)

Change of Altitude in Given Time from Meridian Transit

Altitude Factor: (from above) | (seconds of arc)
Meridian Angle: | (minutes of time)
Change of Altitude: | (minutes of arc)


 Great Circle Sailing

Great Circle Sailing

Origin (Initial Position)

Latitude : degrees minutes
Longitude : degrees minutes

Destination (Final Position)

Latitude : degrees minutes
Longitude : degrees minutes

Results

Initial Course :

degrees true
Great Circle Distance : nautical miles

Way Point Calculations

Way Point Longitude : degrees minutes
Way Point Latitude : degrees minutes


Distance of the Horizon/ Geographic Range Home Page

Distance of the Horizon

Given the Height of Eye, Compute the Distance to the Horizon

Height of eye (specify units): |
 | feet | meters
Distance to the Horizon: | (Nautical Miles)
 | (Statute Miles)


 Relative Humidity and Dew Point

Relative Humidity and Dew Point

This form will compute the relative humidity given the dry and wet-bulb temperatures.

Dry-Bulb Temperature: | °F
Wet-Bulb Temperature: | °F
Relative Humidity: | %
Dew Point: | °F


Latitude and Longitude Factors Home Page

Latitude and Longitude Factors

Latitude: | (degrees)
Azimuth Angle: | (degrees)
The Change of Latitude for a Unit Change in Longitude: |
The Change of Longitude for a Unit Change in Latitude: |


Barometer Measurement Conversions Home Page

Barometer Measurement Conversions

This form allows conversion from one barometer measurement scale to the others. Indicate value you are supplying by selecting the appropriate radio button.

Millibars:
Inches:
Millimeters:


Meridian Angle and Attitude of a Body Home Page

Meridian Angle and Altitude of a Body on the Prime Vertical Circle

Declination of the Celestial Body: | (degrees)
Latitude of the Observer: | (degrees)
Altitude: | (degrees)
Meridian Angle: | (degrees)


Conversion for Meters, Feet and Fathoms Home Page

Conversion for Meters, Feet and Fathoms

Given Meters, Compute Feet and Fathoms

Meters:
Results:
Feet:
Fathoms:

Given Feet, Compute Meters and Fathoms:

Feet:
Meters:
Fathoms:

Given Fathoms, Compute the Meters and Feet:

Fathoms:
Meters:
Feet:


 Mercator Sailing

Mercator Sailing

Origin (Initial Position)
Latitude : degrees minutes
Longitude : degrees minutes

Destination (Final Position)

Latitude : degrees minutes
Longitude : degrees minutes

Results

Course to make : degrees true
Distance to make : nautical miles
Culmulative Distance : nautical miles


Table of Offsets Home Page

Table of Offsets

Altitude:
Distance from the Intercept to
the Point on the LOP to be Offset:
Offset:


Meridional Parts Computation Home Page

Meridional Parts

This page allows calculation of the meridional parts used in the construction of Mercator charts and in Mercator sailing for each minute of latitude from the equator to the poles.

Enter the latitude for which the meridional part is desired. Latitudes may either be entered as decimal degrees by only filling in the degrees field or as degrees and minutes by entering the values in the appropriate fields.

Latitude: | (degrees)
 | (minutes)
Calculated Meridional Parts: |


Altitude Correction for Atmospheric Pressure Home Page

Altitude Correction for Atmospheric Pressure

Apparent Altitude: | (degrees)
 | (minutes)
Atmospheric Pressure: (Specify Units) |
 | inches of mercury | millibars
Altitude Correction: | (minutes)


Geographic Range Home Page

Geographic Range

Given the Height of the Light Above Sea Level and the
Height of the Eye of the Observer above Sea Level,
Compute the Geographic Range

Height of the Light above Sea Level (specify units): |
 | feet | meters
Height of the eye of the Observer above Sea Level (specify units): |
 | feet | meters
Geographic Range: | (Nautical Miles)


Chart Scales and Mile Conversions Home Page

Natural and Numerical Chart Scales

and

Conversion for Nautical and Statute Miles

Given the Scale, Compute Nautical Miles, Statute Miles and Feet

Scale:
Results:
Nautical Miles Per Inch:
Statute Miles Per Inch:
Inches Per Nautical Mile:
Inches Per Statute Mile:
Feet Per Inch:

Convert Nautical Miles to Statute Miles:

Nautical Miles:
Statute Miles:

Convert Statute Miles to Nautical Miles:

Statute Miles:
Nautical Miles:


Speed for Measured Mile and Speed, Time and Distance Home Page

Speed for Measured Mile

and

Speed, Time, and Distance

Speed for a Measured Mile
Given the Time in Seconds, Compute the Speed in Knots
Elapsed time in seconds:
Speed in knots:

Speed, Time and Distance
Given Two Values, Compute the Third:
Speed in knots:
Elapsed time in minutes:
Distance in nautical miles:


 Pub 229

Pub 229

This page allows calculation of the data in the Sight Reduction Tables for Marine Navigation (Pub. No. 229).
The main purpose of this calculator is to facilitate the practice of celestial navigation at sea. A secondary purpose is to provide the solutions of a spherical triangle of which two sides and the included angle are known and it is necessary to find the values of the third side and adjacent angle.

Latitude: | (degrees) | SAME name as declination
 | (minutes) | CONTRARY name to declination
Declination: | (degrees)
 | (minutes)
Local Hour Angle (LHA): | (degrees)
 | (minutes)
Altitude (Hc): | (degrees)
 | (minutes)
Azimuth Angle (Z): | (degrees)
 | (minutes)


Temperature Conversions Home Page

Temperature Conversions

This form allows conversion from one temperature scale to the others. Indicate which scale you are supplying the value for by selecting the appropriate radio button.

Fahrenheit Temp: | (degrees)
Celsius Temp: | (degrees)
Kelvin Temp: | (degrees)


Traverse Computations Home Page

Traverse

This page allows calculation of the data in the Traverse table. Enter known data in the appropriate fields. Place checkmarks next to the fields you want calculated. (Note: At least two of the four values must be provided.)
Course Angle: | (degrees)
 | (minutes)
Difference of Latitude: | (degrees)
 | (minutes)
Departure: | (nautical miles)
Distance: | (nautical miles)


Logarithmic and Trigonometric Calculator Home Page

Logarithmic and Trigonometric Functions Calculator

This calculator will calculate logarithms, trigonometry functions, and the logarithms of trigonometry functions.

Enter the value you want to apply the function to in the field on the right. To calculate the logarighm of the value, check the logarithm box. To calculate the trigonometry function on the value, select the desired function from the list. To calculate the logarighm of a trigonometry function applied to the value, check the logarithm box and choose a trigonometry function.

Check to compute the logarithm | Choose a trigonometry function (or none) | Enter a value:
log10 | none |
 | sine | (Enter all angles in decimal degrees)
 | cosine |
 | tangent
 | cotangent
 | secant
 | cosecant
Result: |


Distance by Vertical Angle (1 of 3)

Distance by Vertical Angle Measured Between Sea Horizon and Top of Object Beyond Sea Horizon

Corrected Vertical Angle: | (degrees)
 | (minutes)
Height of Object Above Horizon (specify units): |
 | feet | meters
Height of the Eye of the Observer (specify units): |
 | feet | meters
Distance: | (Nautical Miles)


Distance by Vertical Angle (2 of 3)

Distance by Vertical Angle Measured Between Waterline at Objectand Top of Object

Corrected Vertical Angle: | (degrees)
 | (minutes)
Height of Object Above Horizon (specify units): |
 | feet | meters
Distance: | (Nautical Miles)


Distance by Vertical Angle (3 of 3)

Distance by Vertical Angle Measured Between Waterline at Object and Sea Horizon Beyond Object

Corrected Vertical Angle: | (degrees)
 | (minutes)
Height of the Eye of the Observer (specify units): |
 | feet | meters
Distance in Yards: |


Direction and Speed of True Wind Home Page

Direction and Speed of True Wind

This form will compute the difference between ship heading and true wind direction and true wind speed. Difference between ship heading and apparent wind direction and apparent wind speed must be provided. Note that if apparent wind speed is supplied in knots, it is necessary to supply the ship speed in knots.

Difference Between Heading and Apparent Wind Direction: | (degrees)
Apparent Wind Speed: (Specify Units) |
 | Units of Ship's Speed | Knots
Ship's Speed: | (knots)
Difference Between Heading and True Wind Direction: | (degrees)
True Wind Speed: | (units of ship's speed)
 | (knots)


Time Zones, Zone Descriptions, and Suffixes Home Page

Time Zones, Zone Descriptions, and Suffixes

Zone | ZD | SUFFIX
7½°W. to 7½°E. | 0 | Z
7½°E. to 22½°E. | -1 | A
22½°E. to 37½°E. | -2 | B
37½°E. to 52½°E. | -3 | C
52½°E. to 67½°E. | -4 | D
67½°E. to 82½°E. | -5 | E
82½°E. to 97½°E. | -6 | F
97½°E. to 112½°E. | -7 | G
112½°E. to 127½°E. | -8 | H
127½°E. to 142½°E. | -9 | I
142½°E. to 157½°E. | -10 | K
157½°E. to 172½°E. | -11 | L
172½°E. to 180° | -12 | M
7½°W. to 22½°W. | 1 | N
22½°W. to 37½°W. | 2 | O
37½°W. to 52½°W. | 3 | P
52½°W. to 67½°W. | 4 | Q
67½°W. to 82½°W. | 5 | R
82½°W. to 97½°W. | 6 | S
97½°W. to 112½°W. | 7 | T
112½°W. to 127½°W. | 8 | U
127½°W. to 142½°W. | 9 | V
142½°W. to 157½°W. | 10 | W
157½°W. to 172½°W. | 11 | X
172½°W. to 180° | 12 | Y